package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]*$`)
var str = `YES
Yes
NOT SURE
NOTSURE
N
no`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}