re = /(?<=id=")\w+(?=")/m
str = 'span id="testing" This is testing span a id="test" link a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end