$re = '/(?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9]\/([^"\']*)/s';
$str = 'https://uptobox.com/krafbomfc1qm
"https://uptobox.com/krafbomfc1qm"
\'https://uptobox.com/krafbomfc1qm\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);