#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:ftp|https?):\/\/(?!0\.0\.0\.0$)(?:(?:(?:1?\d\d?|2[0-4]\d|25[0-5])(?:\.(?!$))?){4}|(?:[a-zA-Z\d]\.|[a-zA-Z\d](?:(?![-.]{2})[a-zA-Z\d-]){0,63}?[a-zA-Z\d]\.){1,63}?[a-z]{2,63})(?:[:/].*)?$"
Local $sString = "---- GOOD ----" & @CRLF & _
"http://10.25.41.81:6000/api/File/GetContentResult?ObjectId=62ab059f5045ea0bb69e00d9" & @CRLF & _
"http://10.25.41.81:6600/api/File/GetContentResult?ObjectId=62ab0d9e5045ea0bb69e00e4" & @CRLF & _
"http://10.25.41.81:6600/api/File/GetContentResult?ObjectId=62a89a8c4f3326cc410c40ef" & @CRLF & _
"http://10.25.41.33:6600/api/File/GetContentResult?ObjectId=62ab04855045ea0bb69e00d7" & @CRLF & _
"https://websitebuilders.com" & @CRLF & _
"https://www.fceboo.k.com/Learn-the-Net-330002341216/" & @CRLF & _
"ftp://aeneas.m.it.edu/" & @CRLF & _
"https://en.wkip.ed-i.org/wiki/Internet#Terminolog" & @CRLF & _
"http://foo.com/blah_blah" & @CRLF & _
"http://foo.com/blah_blah/" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)_(again)" & @CRLF & _
"http://www.example.com/wpstyle/?p=364" & @CRLF & _
"https://www.example.com/foo/?bar=baz&inga=42&quux" & @CRLF & _
"http://a.ws/䨹" & @CRLF & _
"http://foo.com/blah_(wikipedia)#cite-1" & @CRLF & _
"http://foo.com/blah_(wikipedia)_blah#cite-1" & @CRLF & _
"http://foo.com/unicode_(✪)_in_parens" & @CRLF & _
"http://foo.com/(something)?after=parens" & @CRLF & _
"http://code.google.com/events/#&product=browser" & @CRLF & _
"http://js.mp" & @CRLF & _
"ftp://foo.bar/baz" & @CRLF & _
"http://foo.bar/?q=Test%20URL-encoded%20stuff" & @CRLF & _
"http://1337.net" & @CRLF & _
"http://a.b-c.de" & @CRLF & _
"http://223.255.255.254" & @CRLF & _
"https://example.com/././foo" & @CRLF & _
"https://EXAMPLE.com/../x" & @CRLF & _
"https://example.org//" & @CRLF & _
"https://example.org/foo bar" & @CRLF & _
"http://foo.bar/foo(bar)baz quux" & @CRLF & _
"https://example.com:demo" & @CRLF & _
"https://r.com/r/zxVH" & @CRLF & _
"" & @CRLF & _
"---- BAD ----" & @CRLF & _
"https://user:password@example.org/" & @CRLF & _
"http://userid:password@example.com:8080" & @CRLF & _
"http://userid:password@example.com:8080/" & @CRLF & _
"http://userid:password@example.com" & @CRLF & _
"http://userid:password@example.com/" & @CRLF & _
"http://userid@example.com" & @CRLF & _
"http://userid@example.com/" & @CRLF & _
"http://userid@example.com:8080" & @CRLF & _
"http://userid@example.com:8080/" & @CRLF & _
"file://loc%61lhost/" & @CRLF & _
"http://⌘.ws" & @CRLF & _
"http://⌘.ws/" & @CRLF & _
"http://☺.damowmow.com/" & @CRLF & _
"http://✪df.ws/123" & @CRLF & _
"http://[www.example.com]/" & @CRLF & _
"https://ex ample.org/" & @CRLF & _
"file://C|/demo" & @CRLF & _
"\example\..\demo/.\" & @CRLF & _
"https:example.org" & @CRLF & _
"https://////example.com///" & @CRLF & _
"http://0.0.0.0" & @CRLF & _
"http://3628126748" & @CRLF & _
"http://www.foo.bar./" & @CRLF & _
"http://a.b-.co" & @CRLF & _
"http://-a.b.co" & @CRLF & _
"http://-error-.invalid/" & @CRLF & _
"http://~_!$&'()*+,;=:%40:80%2f::::::@example.com" & @CRLF & _
"http://" & @CRLF & _
"http://." & @CRLF & _
"http://.." & @CRLF & _
"http://../" & @CRLF & _
"http://?" & @CRLF & _
"http://??" & @CRLF & _
"http://??/" & @CRLF & _
"http://#" & @CRLF & _
"http://##" & @CRLF & _
"http://##/" & @CRLF & _
"http://foo.bar?q=Spaces should be encoded" & @CRLF & _
"//" & @CRLF & _
"//a" & @CRLF & _
"///a" & @CRLF & _
"///" & @CRLF & _
"http:///a" & @CRLF & _
"foo.com" & @CRLF & _
"rdar://1234" & @CRLF & _
"h://test" & @CRLF & _
"http:// shouldfail.com" & @CRLF & _
":// should fail" & @CRLF & _
"ftps://foo.bar/" & @CRLF & _
"http://.www.foo.bar/" & @CRLF & _
"http://.www.foo.bar./" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")