$re = '/(?<=A)\d+(?=B)/';
$str = 'A12345678B119292A88B2222A883849B123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);