$re = '/(?:\G|\[\w+) (\w+)="(\w+)"/m';
$str = '[person name="Jackson" family="Smith"]
[car brand="Benz" type="SUV"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);