$re = '/(\w+)([ab])\1\2/';
$str = 'hah, haa, dad, wobwob, dada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);