import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TRN\\*[^~\\\\]+";
final String string = "ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04858562 TRN*1*6523251452*5865418282584~\n"
+ "ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04526412 TRN*1*5685952452*158615*6526352 26\\ TRN: 563569856";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}