$re = '/^\+\d{3}-\d{3}-\d{6}$/m';
$str = '+251-911-123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);