$re = '/^.*\/([^\/]+\.jpg).*$/m';
$str = 'PosixPath(\'/content/drive/My Drive/Logo/adidas10.jpg\'),
PosixPath(\'/content/drive/My Drive/Logo/adidas11.jpg\'),
PosixPath(\'/content/drive/My Drive/Logo/adidas13.jpg\'),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);