// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\/([^\/]+\.jpg).*$").unwrap();
let string = "PosixPath('/content/drive/My Drive/Logo/adidas10.jpg'),
PosixPath('/content/drive/My Drive/Logo/adidas11.jpg'),
PosixPath('/content/drive/My Drive/Logo/adidas13.jpg'),";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}