using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?[.]{2})[a-z0-9]+[a-z0-9._%\-+]*[a-z0-9]@[a-z0-9]+[a-z0-9.-]*[a-z0-9]*\.[a-z]{2,24}$";
string input = @"Some very long company name that does not match the regex @%! gfdsa fds dfs fdsa fds fdsa fdsa fdasf dsa fdsa fdsa fdsa fdsafdsfdfdsfsdfsdfsdfdsfsdfdfds fdsafdsaf df fdfdfdsfsdfsffsd";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}