import re
regex = re.compile(r"^(?!.*?[.]{2})[a-z0-9]+[a-z0-9._%\-+]*[a-z0-9]@[a-z0-9]+[a-z0-9.-]*[a-z0-9]*\.[a-z]{2,24}$")
test_str = "Some very long company name that does not match the regex @%! gfdsa fds dfs fdsa fds fdsa fdsa fdasf dsa fdsa fdsa fdsa fdsafdsfdfdsfsdfsdfsdfdsfsdfdfds fdsafdsaf df fdfdfdsfsdfsffsd"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")