package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Additional .*`)
var str = `Additional blah blah blah
Additional Warnings: Whatever
Blah Blah Blah Additional`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}