re = /^Additional .*/m
str = 'Additional blah blah blah
Additional Warnings: Whatever
Blah Blah Blah Additional'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end