package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+:\/\/\/)((\w+\/)+)(\w+.\w+)|(\w+\/\w+.\w+)`)
var str = `client_files/ezsharae.jar
file:///home/aaron/EZShare/ezshare.jar `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}