$re = '/^(?=.*blue)(?=.*pink).+$/m';
$str = 'blue and pink
yellow is the new blue
My pink shirt is so very pink.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);