re = /^(?=.*blue)(?=.*pink).+$/m
str = 'blue and pink
yellow is the new blue
My pink shirt is so very pink.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end