const regex = /\b[A-Z]\w+(?: [A-Z]\w+)*(?= \([A-Z]+\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z]\\w+(?: [A-Z]\\w+)*(?= \\([A-Z]+\\))', 'gm')
const str = `This is a block of text MIDI The USB Device Class Definition for MIDI Devices transmits Music Instrument Digital Interface (MIDI).
I need to select only the "Music Instrument Digital Interface"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}