re = /\b[A-Z]\w+(?: [A-Z]\w+)*(?= \([A-Z]+\))/m
str = 'This is a block of text MIDI The USB Device Class Definition for MIDI Devices transmits Music Instrument Digital Interface (MIDI).
I need to select only the "Music Instrument Digital Interface"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end