$re = '/\b(?=[A-Z\d]{5})[A-Z]*\d[A-Z\d]*/m';
$str = 'AP51711
3M BUFFING MACHINE P64392';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);