re = /\b(?=[A-Z\d]{5})[A-Z]*\d[A-Z\d]*/m
str = 'AP51711
3M BUFFING MACHINE P64392'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end