import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=\\d)(?=(?:\\d+A)?(?:\\d+B)?(?:\\d+C)?(?:,|$))(?:(\\d+)A)?(?:(\\d+)B)?(?:(\\d+)C)?";
final String string = "1A2B3C,80A160B255C,48A30B50C,1A3C,255C,1A,...\n"
+ "48A30B50C,1A,1A1B1C,11111A,1C1B1A,1A1A1A,1C,1B,1443C,adfank,12322134445688,48A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}