import re
regex = re.compile(r"\b(?=\d)(?=(?:\d+A)?(?:\d+B)?(?:\d+C)?(?:,|$))(?:(\d+)A)?(?:(\d+)B)?(?:(\d+)C)?", flags=re.MULTILINE)
test_str = ("1A2B3C,80A160B255C,48A30B50C,1A3C,255C,1A,...\n"
"48A30B50C,1A,1A1B1C,11111A,1C1B1A,1A1A1A,1C,1B,1443C,adfank,12322134445688,48A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")