#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<dl>(?:[^<]+|<(?!/?dl\b)|(?R))*+</dl>"
Local $sString = "<p>" & @CRLF & _
" <span style="visibility:hidden" id="Synonyme">" & @CRLF & _
" <span id="Anker:Synonyme"></span>" & @CRLF & _
" </span>" & @CRLF & _
"</p>" & @CRLF & _
"<div style="margin-bottom:-0.5em; font-weight:bold;" title="bedeutungsgleich gebrauchte Wörter">Synonyme:</div>" & @CRLF & _
"<dl>" & @CRLF & _
" <dd>[1] <a href="/w/index.php?title=Blutsverwandte&action=edit&redlink=1" class="new" title="Blutsverwandte (Seite nicht vorhanden)">Blutsverwandte</a>," & @CRLF & _
" <a href="/wiki/Sippe" title="Sippe">Sippe</a>" & @CRLF & _
" <dl>" & @CRLF & _
" <dd>[1a] <a href="/wiki/Kernfamilie" title="Kernfamilie">Kernfamilie</a></dd>" & @CRLF & _
" <dd>[1b] <i>abwertend, salopp:</i> <a href="/wiki/Mischpoke" title="Mischpoke">Mischpoke</a></dd>" & @CRLF & _
" </dl>" & @CRLF & _
" </dd>" & @CRLF & _
" <dd>[2] <a href="/wiki/Abart" title="Abart">Abart</a>," & @CRLF & _
" <a href="/wiki/Art" title="Art">Art</a>," & @CRLF & _
" <a href="/wiki/Bereich" title="Bereich">Bereich</a>," & @CRLF & _
" <a href="/wiki/Departement" title="Departement">Departement</a>," & @CRLF & _
" <a href="/wiki/Dialekt" title="Dialekt">Dialekt</a>," & @CRLF & _
" <a href="/wiki/Fach" title="Fach">Fach</a>," & @CRLF & _
" <a href="/wiki/Gattung" title="Gattung">Gattung</a>," & @CRLF & _
" <a href="/wiki/Genus" title="Genus">Genus</a>," & @CRLF & _
" <a href="/wiki/Geschlecht" title="Geschlecht">Geschlecht</a>," & @CRLF & _
" <a href="/wiki/Gruppe" title="Gruppe">Gruppe</a>," & @CRLF & _
" <a href="/wiki/Kategorie" title="Kategorie">Kategorie</a>," & @CRLF & _
" <a href="/wiki/Linie" title="Linie">Linie</a>," & @CRLF & _
" <a href="/wiki/Rasse" title="Rasse">Rasse</a>," & @CRLF & _
" <a href="/wiki/Reihe" title="Reihe">Reihe</a>, " & @CRLF & _
" <a href="/wiki/Rubrik" title="Rubrik">Rubrik</a>," & @CRLF & _
" <a href="/wiki/Schlag" title="Schlag">Schlag</a>" & @CRLF & _
" </dd>" & @CRLF & _
"</dl>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")