# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<dl>(?:[^<]+|<(?!/?dl\b)|(?R))*+</dl>"
test_str = ("<p>\n"
" <span style=\"visibility:hidden\" id=\"Synonyme\">\n"
" <span id=\"Anker:Synonyme\"></span>\n"
" </span>\n"
"</p>\n"
"<div style=\"margin-bottom:-0.5em; font-weight:bold;\" title=\"bedeutungsgleich gebrauchte Wörter\">Synonyme:</div>\n"
"<dl>\n"
" <dd>[1] <a href=\"/w/index.php?title=Blutsverwandte&action=edit&redlink=1\" class=\"new\" title=\"Blutsverwandte (Seite nicht vorhanden)\">Blutsverwandte</a>,\n"
" <a href=\"/wiki/Sippe\" title=\"Sippe\">Sippe</a>\n"
" <dl>\n"
" <dd>[1a] <a href=\"/wiki/Kernfamilie\" title=\"Kernfamilie\">Kernfamilie</a></dd>\n"
" <dd>[1b] <i>abwertend, salopp:</i> <a href=\"/wiki/Mischpoke\" title=\"Mischpoke\">Mischpoke</a></dd>\n"
" </dl>\n"
" </dd>\n"
" <dd>[2] <a href=\"/wiki/Abart\" title=\"Abart\">Abart</a>,\n"
" <a href=\"/wiki/Art\" title=\"Art\">Art</a>,\n"
" <a href=\"/wiki/Bereich\" title=\"Bereich\">Bereich</a>,\n"
" <a href=\"/wiki/Departement\" title=\"Departement\">Departement</a>,\n"
" <a href=\"/wiki/Dialekt\" title=\"Dialekt\">Dialekt</a>,\n"
" <a href=\"/wiki/Fach\" title=\"Fach\">Fach</a>,\n"
" <a href=\"/wiki/Gattung\" title=\"Gattung\">Gattung</a>,\n"
" <a href=\"/wiki/Genus\" title=\"Genus\">Genus</a>,\n"
" <a href=\"/wiki/Geschlecht\" title=\"Geschlecht\">Geschlecht</a>,\n"
" <a href=\"/wiki/Gruppe\" title=\"Gruppe\">Gruppe</a>,\n"
" <a href=\"/wiki/Kategorie\" title=\"Kategorie\">Kategorie</a>,\n"
" <a href=\"/wiki/Linie\" title=\"Linie\">Linie</a>,\n"
" <a href=\"/wiki/Rasse\" title=\"Rasse\">Rasse</a>,\n"
" <a href=\"/wiki/Reihe\" title=\"Reihe\">Reihe</a>, \n"
" <a href=\"/wiki/Rubrik\" title=\"Rubrik\">Rubrik</a>,\n"
" <a href=\"/wiki/Schlag\" title=\"Schlag\">Schlag</a>\n"
" </dd>\n"
"</dl>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.