import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?P<type>(?:feat)|(?:fix)|(?:docs)|(?:style)|(?:refactor)|(?:test)|(?:merge)|(?:chore))(?: \\((?P<issue>.+)\\))?: (?P<subject>[A-Z0-9].{0,48}(?!\\.).?)\\n?)(?:\\n(?P<body>(?:.*\\n?)+))*$";
final String string = "feat: Summarize changes in around 50 characters or less\n\n"
+ "More detailed explanatory text, if necessary. Wrap it to about 72\n"
+ "characters or so. In some contexts, the first line is treated as the\n"
+ "subject of the commit and the rest of the text as the body. The\n"
+ "blank line separating the summary from the body is critical (unless\n"
+ "you omit the body entirely); various tools like `log`, `shortlog`\n"
+ "and `rebase` can get confused if you run the two together.\n\n"
+ "Explain the problem that this commit is solving. Focus on why you\n"
+ "are making this change as opposed to how (the code explains that).\n"
+ "Are there side effects or other unintuitive consequences of this\n"
+ "change? Here's the place to explain them.\n\n"
+ "Further paragraphs come after blank lines.\n\n"
+ " - Bullet points are okay, too\n\n"
+ " - Typically a hyphen or asterisk is used for the bullet, preceded\n"
+ " by a single space, with blank lines in between, but conventions\n"
+ " vary here\n\n"
+ "If you use an issue tracker, put references to them at the bottom,\n"
+ "like this:\n\n"
+ "Resolves: #123\n"
+ "See also: #456, #789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}