import re
regex = re.compile(r"^(?:(?P<type>(?:feat)|(?:fix)|(?:docs)|(?:style)|(?:refactor)|(?:test)|(?:merge)|(?:chore))(?: \((?P<issue>.+)\))?: (?P<subject>[A-Z0-9].{0,48}(?!\.).?)\n?)(?:\n(?P<body>(?:.*\n?)+))*$", flags=re.MULTILINE)
test_str = ("feat: Summarize changes in around 50 characters or less\n\n"
"More detailed explanatory text, if necessary. Wrap it to about 72\n"
"characters or so. In some contexts, the first line is treated as the\n"
"subject of the commit and the rest of the text as the body. The\n"
"blank line separating the summary from the body is critical (unless\n"
"you omit the body entirely); various tools like `log`, `shortlog`\n"
"and `rebase` can get confused if you run the two together.\n\n"
"Explain the problem that this commit is solving. Focus on why you\n"
"are making this change as opposed to how (the code explains that).\n"
"Are there side effects or other unintuitive consequences of this\n"
"change? Here's the place to explain them.\n\n"
"Further paragraphs come after blank lines.\n\n"
" - Bullet points are okay, too\n\n"
" - Typically a hyphen or asterisk is used for the bullet, preceded\n"
" by a single space, with blank lines in between, but conventions\n"
" vary here\n\n"
"If you use an issue tracker, put references to them at the bottom,\n"
"like this:\n\n"
"Resolves: #123\n"
"See also: #456, #789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")