import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:SELECT\\s+|,\\s*)[\\s\\S]*?\\s?([^,]+?)\\s+AS\\s+Error.*";
final String string = "SELECT t1.dummy1, t1.dummy2 AS Error, t1.dummy3 INTO testResult\n"
+ "FROM (test1 t1 INNER JOIN test2 t2 ON t1.dummy4 = t2.dummy4) INNER JOIN test3 t3 ON t2.dummy9 = t3.dummy9 \n"
+ "WHERE t2.dummy6 = 'abc' AND t3.dummy10 <> 'def' AND t1.dummy11 = 'ghi' AND t2.dummy12 IS NULL\n"
+ "GROUP BY t1.dummy1\n"
+ "HAVING 1=1\n"
+ "ORDER BY 1;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}