$re = '/(?:SELECT\s+|,\s*)[\s\S]*?\s?([^,]+?)\s+AS\s+Error.*/m';
$str = 'SELECT t1.dummy1, t1.dummy2 AS Error, t1.dummy3 INTO testResult
FROM (test1 t1 INNER JOIN test2 t2 ON t1.dummy4 = t2.dummy4) INNER JOIN test3 t3 ON t2.dummy9 = t3.dummy9
WHERE t2.dummy6 = \'abc\' AND t3.dummy10 <> \'def\' AND t1.dummy11 = \'ghi\' AND t2.dummy12 IS NULL
GROUP BY t1.dummy1
HAVING 1=1
ORDER BY 1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);