import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/api\\/front\\/reference\\/(.*)(\\?+)(.*)";
final String string = "api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full?_locale=fr_FR\n"
+ "api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}