const regex = /\/api\/front\/reference\/(.*)(\?+)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/api\\\/front\\\/reference\\\/(.*)(\\?+)(.*)', 'gm')
const str = `api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full?_locale=fr_FR
api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}