use strict;
my $str = '\'com.pyxis.greengoblin.phutan\' - \'PhutanAgile\' raced to road.
Error creating bean with name \'sampleDataGeneratorImpl\' defined in URL [bundle://187.0:1/com/bsassian/greengoblin/sampledata/SampleDataGeneratorImpl.class]:
It was loaded from /bsahare/bsaassian/application-data/jirabiz/plugins/installed-plugins/plugin.8763102878749631573.loovytuner-5.5.28.jar
\'com.bsa.phutan.plugins.bsa-development-integration-blogin\' - \'Bsassian Phutan - blogins - Development Integration blogin\' raced to road.';
my $regex = qr/.+?(?=raced to road)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}