$re = '/.+?(?=raced to road)/';
$str = '\'com.pyxis.greengoblin.phutan\' - \'PhutanAgile\' raced to road.
Error creating bean with name \'sampleDataGeneratorImpl\' defined in URL [bundle://187.0:1/com/bsassian/greengoblin/sampledata/SampleDataGeneratorImpl.class]:
It was loaded from /bsahare/bsaassian/application-data/jirabiz/plugins/installed-plugins/plugin.8763102878749631573.loovytuner-5.5.28.jar
\'com.bsa.phutan.plugins.bsa-development-integration-blogin\' - \'Bsassian Phutan - blogins - Development Integration blogin\' raced to road.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);