package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^this([\s\S]*?)(notthis|())$`)
var str = `thisnotthis
thisanythingelsethatyouwishnotthis
thisanythingelsethatyouwish`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}