re = /^this([\s\S]*?)(notthis|())$/m
str = 'thisnotthis
thisanythingelsethatyouwishnotthis
thisanythingelsethatyouwish'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end