$re = '/.*(?= \S+ \S+)/';
$str = 'Level production data TD Index
Total Agriculture\\Production data TS Index';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);