re = /.*(?= \S+ \S+)/
str = 'Level production data TD Index
Total Agriculture\\Production data TS Index'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end