$re = '/10\.\d+\.\d+\.\d$/m';
$str = '10.63.69.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);