$re = '/(\(.*\))?(?:\s(\(thisshouldbegrouptwo\)\s))?(\(.*\))/m';
$str = '(this) (should) (be) (group) (one) (thisshouldbegrouptwo) (this) (should) (be) (group) (three)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);