import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^,]*\\,){9}(.*?)\\,";
final String string = "<13>Apr 20 16:19:36 SERVERNAME.domain.net 1,2021/04/20 16:19:36,013244444796,THREAT,data,2049,2021/04/20 16:19:36,1.1.1.1,2.2.2.2,3.3.3.3,4.4.4.4,FWRULE NAME,,,sharepoint-online-uploading,vsys1,fwrulename,zone,protocol.stuff,ethernet1/1,SourceOS,2021/04/20 16:19:36,34916,1,49538,443,11070,443,0x1406000,tcp,alert,\"'FILE_01.docx'\",DataPattern-Conf(60004),computer-and-internet-info,low,client-to-server,69181231233089036,0xa000000000000000,100.0.0.0-100.255.255.255,United States,0,,0,,,3,,,,,,,,0,13,14,35,11,,SERVERNAME,,,,,0,,0,,N/A,unknown,AppThreat-0-0,0x0,0,424949495,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}