// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[^,]*\,){9}(.*?)\,").unwrap();
let string = "<13>Apr 20 16:19:36 SERVERNAME.domain.net 1,2021/04/20 16:19:36,013244444796,THREAT,data,2049,2021/04/20 16:19:36,1.1.1.1,2.2.2.2,3.3.3.3,4.4.4.4,FWRULE NAME,,,sharepoint-online-uploading,vsys1,fwrulename,zone,protocol.stuff,ethernet1/1,SourceOS,2021/04/20 16:19:36,34916,1,49538,443,11070,443,0x1406000,tcp,alert,\"'FILE_01.docx'\",DataPattern-Conf(60004),computer-and-internet-info,low,client-to-server,69181231233089036,0xa000000000000000,100.0.0.0-100.255.255.255,United States,0,,0,,,3,,,,,,,,0,13,14,35,11,,SERVERNAME,,,,,0,,0,,N/A,unknown,AppThreat-0-0,0x0,0,424949495,";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}