#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!admin|public(?:$|\/))([a-z0-9]+)(?:\/([a-zA-Z0-9._\/]*))?$"
Local $sString = "api/" & @CRLF & _
"api" & @CRLF & _
"api.set/" & @CRLF & _
"api/newsfeed.get/" & @CRLF & _
"api/news.getcomments" & @CRLF & _
"d/" & @CRLF & _
"d/26" & @CRLF & _
"d/26/" & @CRLF & _
"d/26/taxo" & @CRLF & _
"" & @CRLF & _
"mypanel/admin" & @CRLF & _
"public/kekwo" & @CRLF & _
"publication/" & @CRLF & _
"publication" & @CRLF & _
"news/21" & @CRLF & _
"news" & @CRLF & _
"news/" & @CRLF & _
"" & @CRLF & _
"d" & @CRLF & _
"d/26" & @CRLF & _
"over9000" & @CRLF & _
"video100500/" & @CRLF & _
"" & @CRLF & _
"user/dreamer" & @CRLF & _
"user/HateYouCheater" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")