use strict;
my $str = 'api/
api
api.set/
api/newsfeed.get/
api/news.getcomments
d/
d/26
d/26/
d/26/taxo
mypanel/admin
public/kekwo
publication/
publication
news/21
news
news/
d
d/26
over9000
video100500/
user/dreamer
user/HateYouCheater
';
my $regex = qr/^(?!admin|public(?:$|\/))([a-z0-9]+)(?:\/([a-zA-Z0-9._\/]*))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}