$re = '/(?<=\=)(.*?)(?=\&)/mi';
$str = 'https://www.youtube.com/watch?v=4HFK9nwsIJc&feature=youtu.be';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);