re = /(?<=\=)(.*?)(?=\&)/mi
str = 'https://www.youtube.com/watch?v=4HFK9nwsIJc&feature=youtu.be'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end