package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+ (\(Home\)|\(Cell\))`)
var str = `1234567890 (Home) or 1234567890 (Cell)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}