$re = '/\d+ (\(Home\)|\(Cell\))/m';
$str = '1234567890 (Home) or 1234567890 (Cell)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);