#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((g[íìỉĩị]|q[úùủũụứừửữự])[aăâeêoôơuưiy])[a-z]*|([bcdfhjklmnprstvxzđ]*[aăâeoôơuưiy][áàảãạắằẳẵặấầẩẫậéèẻẽẹóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị])$|([a-zđ]*[áàảãạắằẳẵặấầẩẫậéèẻẽẹóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị][aăâêeoôơuưiy][aăâeêoôơuưiybcdfghklmnpqrstvx]+)|([bcdfghjklmnpqrstvxzđ]*[aăâêeoôơuưiy][aăâêeoôơuưiy][áàảãạắằẳẵặấầẩẫậéèẻẽẹóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị][bcdfghjklmnpqrstvxz]*)|([a-zăâôơưđ]*[áàảãạắằẳẵặấầẩẫậóòỏõọốồổỗộờớởỡợúùủũụứừửữựýỳỷỹỵíìỉĩị][a-z]*ê[a-zăâôơư]*)|([a-zăâôêưđ]*[áàảãạắằẳẵặấầẩẫậếềểễệóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị][a-z]*ơ[a-zăâôơư]*)"
Local $sString = "hoạ" & @CRLF & _
"hoà" & @CRLF & _
"haọ" & @CRLF & _
"keó" & @CRLF & _
"meọ" & @CRLF & _
"coí" & @CRLF & _
"" & @CRLF & _
"gían" & @CRLF & _
"gíong" & @CRLF & _
"gíêng" & @CRLF & _
"qúa" & @CRLF & _
"qúan" & @CRLF & _
"gìau" & @CRLF & _
"gìêng" & @CRLF & _
"" & @CRLF & _
"chụyên" & @CRLF & _
"chuỵên" & @CRLF & _
"lúyên" & @CRLF & _
"luỵên" & @CRLF & _
"túê" & @CRLF & _
"tụê" & @CRLF & _
"" & @CRLF & _
"hòang" & @CRLF & _
"hùynh" & @CRLF & _
"tòan" & @CRLF & _
"tươí" & @CRLF & _
"toaì" & @CRLF & _
"tóai" & @CRLF & _
"" & @CRLF & _
"chuyện" & @CRLF & _
"nguyễn" & @CRLF & _
"hào" & @CRLF & _
"pháo" & @CRLF & _
"táo" & @CRLF & _
"tợn" & @CRLF & _
"huỳnh" & @CRLF & _
"hoàng" & @CRLF & _
"choáng" & @CRLF & _
"láng" & @CRLF & _
"ngáng"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")