import re
regex = re.compile(r"((g[íìỉĩị]|q[úùủũụứừửữự])[aăâeêoôơuưiy])[a-z]*|([bcdfhjklmnprstvxzđ]*[aăâeoôơuưiy][áàảãạắằẳẵặấầẩẫậéèẻẽẹóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị])$|([a-zđ]*[áàảãạắằẳẵặấầẩẫậéèẻẽẹóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị][aăâêeoôơuưiy][aăâeêoôơuưiybcdfghklmnpqrstvx]+)|([bcdfghjklmnpqrstvxzđ]*[aăâêeoôơuưiy][aăâêeoôơuưiy][áàảãạắằẳẵặấầẩẫậéèẻẽẹóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị][bcdfghjklmnpqrstvxz]*)|([a-zăâôơưđ]*[áàảãạắằẳẵặấầẩẫậóòỏõọốồổỗộờớởỡợúùủũụứừửữựýỳỷỹỵíìỉĩị][a-z]*ê[a-zăâôơư]*)|([a-zăâôêưđ]*[áàảãạắằẳẵặấầẩẫậếềểễệóòỏõọốồổỗộúùủũụứừửữựýỳỷỹỵíìỉĩị][a-z]*ơ[a-zăâôơư]*)", flags=re.MULTILINE)
test_str = ("hoạ\n"
"hoà\n"
"haọ\n"
"keó\n"
"meọ\n"
"coí\n\n"
"gían\n"
"gíong\n"
"gíêng\n"
"qúa\n"
"qúan\n"
"gìau\n"
"gìêng\n\n"
"chụyên\n"
"chuỵên\n"
"lúyên\n"
"luỵên\n"
"túê\n"
"tụê\n\n"
"hòang\n"
"hùynh\n"
"tòan\n"
"tươí\n"
"toaì\n"
"tóai\n\n"
"chuyện\n"
"nguyễn\n"
"hào\n"
"pháo\n"
"táo\n"
"tợn\n"
"huỳnh\n"
"hoàng\n"
"choáng\n"
"láng\n"
"ngáng")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")